AndroidLab

Il Laboratorio Italiano Android e Google Chrome

A poche settimane dal lancio ufficiale di Android 2.2 sul Droid, e mentre noi utenti del Milestone dovremmo attendere fino a novembre (se ci dice bene), rilascio che abilitava il supporto a Flash, ed infatti così è per i cugini americani che hanno il Droid. Adobe oggi, con sorpresa, ha messo mano ai requisiti minimi per terminali Android con schermi WVGA, aumentandoli naturalmente.

Come potete leggere in fondo a questa pagina, i requisiti per i terminali con risoluzione WVGA sono passati ad essere una frequenza di clock del processore di 800MHz.

Cosa vorrà dire questo?, che i possessori del Droid non riceveranno più aggiornamenti per quanto riguarda Flash, o che addirittura verrà disabilitato?
Ma soprattutto, visto che per il Milestone deve ancora uscire, lo vedremo mai a questo punto (ufficialmente intendo)?

Certo sappiamo che il processore di questi device regge tranquillamente frequenze di 800MHz e anche più overclockandolo, del resto fu una scelta di Motorola quella di abbassare la frequenza a 550MHz, di fabrica il processore funziona tranquillamente a frequenze superiori. Quindi magari si spera che Adobe faccia un eccezione ai requisiti per questi due device fratelli.

Ragionando sul perchè di questo aumento dei requisiti, le cause possono esser due, o semplicemente le performance sono veramente penose o  è un aumento con uno sguardo al futuro, che si traduce in nuove versioni di Flash che dipenderanno ancora di più dalla CPU. Vedremo quale delle due.

Considerazione mia personale, tutta questa telenovela di Adobe su Flash sta un po’ stancando, è quasi un anno che se ne parla e la situazione è ancora questa, con Adobe che ancora non sa bene nemmeno lei quanta potenza ci vuole per far andare Flash decentemente.
Del resto lo si più vedere anche con i sistemi desktop, sono anni che non viene ottimizzato il codice di Flash, potenza del processore o meno, se un codice è fatto male, girerà sempre male a prescindere.
Ma ancora una volta a noi almeno è dato il dono di poter scegliere se “beneficiarne” o meno di Flash.

Michele Dipace

Admin di Androidlab e "Computer Addicted", ha cominciato la sua"carriera" nella metà degli anni 80 sui computer 8 bit Commodore e Sinclair passando poi al 16 bit Amiga, diventandone grande appassionato. Oggi Linux user, crede che Android sia il sistema operativo destinato ad emergere nel mercato della telefonia mobile.

More Posts - Website

Follow Me:
TwitterFacebookLinkedInPinterestGoogle PlusYouTube

  • kirkluigi

    Ciao Enrico ma sei sicuro che è stata aggiornata da poco?…a me sembra che il requisito di 800mhz ci sia sempre stato…da quando si parla di flash per android io in quella pagina ho sempre letto 550 per vga e 800 per wvga

    • kirkluigi

      e poi guarda qui… http://www.adobe.com/flashplatform/supported_devi
      c è anche il droid tra gli smartphone supportati…cmq sono piuttosto sicuro che gli 800 ci siano sempre stati come requisito

      • EnricoDroid

        che sia stato aggiornato da poco non so, non ci metto la mano sul fuoco, ho letto la notizia riportata da blog stranieri, in particolare dal blog droid-life, ho controllato, aspettato un po' per eventuali aggiornamento sulla notizia, e poi ho fatto il mio articolo.
        Io di come eventualmente era prima non ho proprio memoria quindi non potevo confrontare, ho controllato la cache di google, ma per siti come quello di adobe è praticamente sincronizzata.
        Comunque, cambiati o meno, il discorso più o meno rimane, sopratutto le conclusioni mie.

        L'altro link che dai, fa vedere i terminali su cui è disponibile ora, e ho scritto che il droid1 ce l'ha avuto, per questo era in contraddizione con i requisiti indicati. Forse la cosa si raggira con il fatto che il kernel stock motorola froyo del droid (e si spera anche del milestone) è in effetti clockato a 800MHz, fin dalle prime leak se ricordi.

        • kirkluigi

          anche qui enrico adobe parla esplicitamente di milestone… http://www.adobe.com/aboutadobe/pressroom/pressre
          cmq mi ricordo benissimo che lessi quei requisiti da appena si parlava della prima beta di flash..non capisco perche solo ora se ne parla…il droid è supportato lo stesso nonostante gli 800 e lo sara anche il milestone..non avrebbe senso il contrario

        • EnricoDroid

          si si.i comunicati del passato li conosco tutti e ricordo che il milestone era citato in modo esplicito.
          Perchè dei requisiti se ne parla solo ora non so dirtelo, io ho verificato nelle mie possibilità la notizia e commentata.
          Droid e Milestone sono a tutti gli effetti fuori dai requisiti, poi per adobe l'hw è comunque certificato a supportarlo, e così è alla fine. Questo dimostra solo che i requisiti lasciano il tempo che trovano, forse altri device fuori dai requisiti possono supportarlo, ma non hanno magari motorola dietro che ha sicuramente fatto pressione su adobe per far un'eccezione (visto anche che il droid era stato pubblicizzato come flash ready, con rischio di class action se così non fosse stato).

          Il mio discorso è motorola punta a sparare numeri alti di requisiti in modo da non dover lavorare sull'ottimizzazione. Flash rimane grossolano ed usa tutta la potenza che può usare dai processori moderni.

  • Fabio

    Lo sapete che se Motorola non porta (in un modo o in un altro) Flash sul Milestone è possibile chiedere (restituendo il telefono) il rimborso del costo del telefono? Questo perché sia sul sito che sulla confezione del Milestone c'è scritto chiaramente che era predisposto per Flash e Motorola aveva giurato che appena Flash 10.1 fosse stato disponibile, ci sarebbe stato un aggiornamento del sistema.
    Se questo aggiornamento non ci sarà, è possibile chiedere a Motorola il rimborso perché il device non è conforme alle specifiche.

  • giovanni

    ahhaha che ridere… questo scambia le notizie di 3 mesi fa per news…

    • A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.

      Mi sembra che la discussione che volevo aprire era un'altra, le mie conclusioni rimangono anche se la notizia era di un anno fa e l'ho scritto chiaramente anche nei commenti precedenti.
      Comunque "questo" è in buona compagnia, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
      Androidiani.it
      Androidworld.it
      phandroid.com
      mobiflip.de
      droid-life.com
      androidpolice.com
      Questi sono solo quelli che seguo, ma sicuramente anche altri.
      Personalmente ho, come detto, appreso la notizia per prima da droid-life.com. Magari dai uno sguardo e posta questo tuo stesso commento anche in ognuno di quelli elencati se hai tempo da perdere, intelligenti pauca.

      Comunque leggendo tutti i commenti di droid-life all'articolo e di mobiflip.de le due sorgenti primarie della notizia (così sembra) nessuno ha fatto notare ad oggi che erano sempre stati questi i requisiti. Mi fido di kirkluigi, non vedo perché non dovrebbe essere altrimenti, quindi semplicemente tutti non hanno memoria come me.

      Come già scritto volevo aprire una discussione su un altro fronte, non la data dei requisiti, ma sul comportamento di Adobe, ricordo che anche se il droid ha installato falsh (dopo successivo aggiornamento da parte di verizon non motorola, il primo aggiornamento a froyo non permetteva di installarlo) non va come va sul nexus a frequenza stock, indice che sul droid c'è, e ci sarà anche per il milestone, solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, ma una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

    • A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.

      Mi sembra che la discussione che volevo aprire era un'altra, le mie conclusioni rimangono anche se la notizia era di un anno fa e l'ho scritto chiaramente anche nei commenti precedenti.
      Comunque "questo" è in buona compagnia credo, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
      Androidiani.it
      Androidworld.it
      phandroid.com
      mobiflip.de
      droid-life.com
      androidpolice.com
      Questi sono solo quelli che seguo, ma sicuramente anche altri.
      Personalmente ho, come detto, appreso la notizia per prima da droid-life.com.
      Magari dai uno sguardo e posta questo stesso tuo commento anche in ognuno di essi se hai tempo da perdere, intelligenti pauca.

      Comunque leggendo tutti i commenti di droid-life all'articolo e di mobiflip.de le due sorgenti primarie della notizia (così sembra) nessuno ha fatto notare ad oggi che erano sempre stati questi i requisiti. Mi fido di kirkluigi, non vedo perché non dovrebbe essere altrimenti, quindi semplicemente tutti non hanno memoria come me.

      Come già scritto volevo aprire una discussione su un altro fronte, non la data dei requisiti, ma sul comportamento di Adobe, ricordo che anche se il droid ha installato falsh (dopo successivo aggiornamento da parte di verizon non motorola, il primo aggiornamento a froyo non permetteva di installarlo) non va come va sul nexus a frequenza stock, indice che sul droid c'è, e ci sarà anche per il milestone, solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, ma una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

    • A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.

      La discussione che volevo aprire era un'altra, le mie conclusioni rimangono anche se la notizia era di un anno fa e l'ho scritto chiaramente anche nei commenti precedenti.
      Comunque "questo" è in buona compagnia credo, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
      Androidiani.it
      Androidworld.it
      phandroid.com
      mobiflip.de
      droid-life.com
      androidpolice.com
      Questi sono solo quelli che seguo, ma sicuramente anche altri.
      Personalmente ho, come detto, appreso la notizia per prima da droid-life.com.
      Magari dai uno sguardo e posta questo stesso tuo commento anche in ognuno di essi se hai tempo da perdere, intelligenti pauca.

      Come già scritto volevo aprire una discussione su un altro fronte, non la data dei requisiti, ma sul comportamento di Adobe, ricordo che anche se il droid ha installato falsh (dopo successivo aggiornamento da parte di verizon non motorola, il primo aggiornamento a froyo non permetteva di installarlo) non va come va sul nexus a frequenza stock, indice che sul droid c'è, e ci sarà anche per il milestone, solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, ma una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

    • A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.
      Comunque "questo" è in buona compagnia credo, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
      Androidiani.it
      Androidworld.it
      phandroid.com
      mobiflip.de
      droid-life.com
      androidpolice.com
      Personalmente ho, come detto, appreso la notizia per prima da droid-life.com.
      Magari dai uno sguardo e pubblica tuo commento anche in ognuno di essi se hai tempo da perdere, intelligenti pauca.

      Come già scritto volevo aprire una discussione su un altro fronte, sul comportamento di Adobe, il discorso era che anche se il droid ha installato flash (dopo successivo aggiornamento da parte di verizon non motorola, il primo aggiornamento a froyo non permetteva di installarlo) solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

    • A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.
      Comunque "questo" è in buona compagnia credo, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
      Androidiani.it, Androidworld.it, phandroid.com, mobiflip.de, droid-life.com, androidpolice.com.
      Personalmente ho, come detto, appreso la notizia per prima da droid-life.com.
      Magari dai uno sguardo e pubblica tuo commento anche in ognuno di essi se hai tempo da perdere, intelligenti pauca.

      Come già scritto volevo aprire una discussione su un altro fronte, sul comportamento di Adobe, il discorso era che anche se il droid ha installato flash (dopo successivo aggiornamento da parte di verizon non motorola, il primo aggiornamento a froyo non permetteva di installarlo) solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

    • EnricoDroid

      A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.

      Mi sembra che la discussione che volevo aprire era un'altra, le mie conclusioni rimangono anche se la notizia era di un anno fa e l'ho scritto chiaramente anche nei commenti precedenti.
      "questo" è in buona compagnia credo, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
      Androidiani.it
      Androidworld.it
      phandroid.com
      mobiflip.de
      droid-life.com
      androidpolice.com
      Questi sono solo quelli che seguo, ma sicuramente anche altri.
      Personalmente ho, come detto, appreso la notizia per prima da droid-life.com.
      Magari dai uno sguardo e posta questo stesso tuo commento anche in ognuno di essi se hai tempo da perdere, intelligenti pauca.

      Leggendo tutti i commenti di droid-life all'articolo e di mobiflip.de le due sorgenti primarie della notizia (così sembra) nessuno ha fatto notare ad oggi che erano sempre stati questi i requisiti. Mi fido di kirkluigi, non vedo perché non dovrebbe essere altrimenti, quindi semplicemente tutti non hanno memoria come me.

      Come già scritto volevo aprire una discussione su un altro fronte, non la data dei requisiti, ma sul comportamento di Adobe, ricordo che anche se il droid ha installato flash (solo dopo secondo aggiornamento da parte di verizon) non va come va sul nexus, indice che sul droid c'è, e ci sarà anche per il milestone, solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, ma una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

  • A parte il fatto che "questo" lo dici a tuo zio, se hai qualcosa da dire oltre a commentare a caso, ci sono modi e modi.
    Comunque "questo" è in buona compagnia credo, non credi?…questi sono alcuni tra i blog, italiani e stranieri, che hanno pubblicato la notizia:
    Androidiani.it, Androidworld.it, phandroid.com, mobiflip.de, droid-life.com, androidpolice.com.
    Personalmente ho, come detto, appreso la notizia per prima da droid-life.com.
    Magari dai uno sguardo e pubblica tuo commento anche in ognuno di essi se hai tempo da perdere, intelligenti pauca.
    Come già scritto volevo aprire una discussione su un altro fronte, sul comportamento di Adobe, il discorso era che anche se il droid ha installato flash (dopo un secondo aggiornamento da parte di verizon non motorola) solo perchè motorola spinge per farcelo stare per forza, per evitare quello che anche Fabio ha ricordato, una volta messo questo non vuol dire che in futuro continuerà a supportarlo.

Forum Android
Diventa un blogger, scrivi un articolo